🌙
 

Subscribe to the Taegis™ XDR Documentation RSS Feed at .

Learn more about RSS readers or RSS browser extensions.

Red Cloak™ Endpoint Agent Supported Operating Systems and System Requirements

integrations endpoints red cloak secureworks edr


Microsoft Windows

Minimum System Requirements

Note

These minimum system requirements are recommended for the majority of installations, but because every endpoint is different and operates under varying conditions, additional resources may be needed.

Important

Red Cloak™ Endpoint Agent is not tested to run alongside any specific container tool and therefore does not support any form of container management.

Supported Operating Systems

OS Agent Version
Windows Server 2019 2.0.7.9 and later
Windows Server 2016 2.0.7.9 and later
Windows Server Core 2016 2.0.7.9 and later
Windows Server 2012 R2* 2.0.7.9 and later
Windows Server 2012* 2.0.7.9 and later
Windows Server 2008 R2* 2.1.4.0 and later
Windows 10* 2.0.7.9 and later
Windows 8.1* 2.0.7.9 and later
Windows 8* 2.0.7.9 and later
Windows 7 SP1* 2.0.7.9 and later

* 64 and 32-bit versions are supported

Note

For information on SHA signing support for Windows, especially older versions, see 2019 SHA-2 Code Signing Support requirement for Windows and WSUS. Also see this security advisory on SHA code signing: Microsoft Security Advisory 3033929.

Linux

Minimum System Requirements

Note

These minimum system requirements are recommended for the majority of installations, but because every endpoint is different and operates under varying conditions, additional resources may be needed.

Important

Red Cloak™ Endpoint Agent is not tested to run alongside any specific container tool and therefore does not support any form of container management.

Supported Operating Systems

OS Agent Version
Red Hat Enterprise Linux / CentOS / Oracle Linux 8.3 1.2.15.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 8.2 1.2.12.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 8.1 1.2.12.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 8.0 1.2.12.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.9 1.2.15.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.8 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.7 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.6 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.5 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.4 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.3 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.2 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.1 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 7.0 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 6.10 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 6.9 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 6.8 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 6.7 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 6.6 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 6.5 1.2.6.0 and later
Red Hat Enterprise Linux / CentOS / Oracle Linux 6.4 1.2.6.0 and later
Amazon Linux 2 1.2.8.0 and later
Ubuntu 20.04 1.2.13.0 and later
Ubuntu 18.04 1.2.13.0 and later
Ubuntu 16.04 1.2.13.0 and later

Which Operating Systems is Red Cloak™ Endpoint Agent NOT supported on?

Red Cloak™ Endpoint Agent is tested and verified on all operating systems listed as supported by Secureworks. In cases where Red Cloak™ Endpoint Agent supports an operating system that is no longer supported by the operating system vendor, troubleshooting and remediation of performance and other issues that arise may be limited and could be deemed out of scope for the service at the discretions of Secureworks.

Microsoft Windows Limited Support

The following operating systems have limited support in Red Cloak™ Endpoint Agent:

Microsoft Windows Not Supported

Red Cloak™ Endpoint Agent is NOT supported on the following operating systems:

Any Windows OS version that is not in the supported list above, including non-English language packs, is not supported. Red Cloak™ Endpoint Agent is not supported on systems running Itanium processors.

Red Cloak™ Endpoint Agent Version

See Red Cloak™ Endpoint Agent Changelog for version updates.

 

On this page: